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About Us
Badan Nasional Penanggulangan Bencana (BNPB)

BNPB is Indonesia’s National Disaster Management Agency. BNPB is
a non-departmental ministerial-level government agency, tasked with
providing guidance and direction to the efforts of disaster
management that includes disaster prevention, emergency response,
rehabilitation, and reconstruction in a fair and equal. National Disaster
Management Agency has the function as a policy maker and
formulator and Refugee (IDP) management to act quickly and
appropriately and effectively and efficiently; and coordinating the
implementation of disaster management activities in a planned,
integrated, and comprehensive.

http://bnpb.go.id
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Australia-Indonesia Facility for Disaster Reduction
(AIFDR)

The Australia-Indonesia Facility for Disaster Reduction (AIFDR) is a
joint initiative between the governments of Australia and Indonesia.
We work to strengthen Indonesia's ability to reduce the impact of
disasters. The Australian and Indonesian governments at a special
ceremony on 15 July 2010 launched the Australia-Indonesia facility.
The launch marks an important event in the strong relationship now
shared by both countries and their united commitment to better
prepare for and respond to natural disasters in Indonesia.

http://aifdr.org

Humanitarian OpenStreetMap Team (HOT)
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Free, collaborative maps are uniquely valuable to humanitarian work,
especially in places where base map data is often scarce, out of date,
or rapidly changing. OpenStreetMap is a web project to create a free
and open map of the entire world, built entirely by volunteers
surveying with GPS, digitizing aerial imagery, and collecting and
liberating existing public sources of geographic data. The
Humanitarian OpenStreetMap Team (HOT) is an initiative to apply
the principles and activities of open source and open data sharing
towards humanitarian response and economic development.

http://hot.openstreetmap.org

Universitas Gadjah Mada (UGM)

Universitas Gadjah Mada (internationally known as Gadjah Mada
University; Abbreviation : UGM) is an Indonesian public ivy league
research university located in Yogyakarta, Indonesia. Department of
Geodetic Engineering, Faculty of Engineering focuses on education,
research, and commmunity services related to geodesy and geomatics
engineering, including acquisition, analysis, and uses of detailed and
accurate geospatial data and large-scale maps using open source
geospatial software for disaster management.

http://ugm.ac.id
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Preface
A Geographic Information System (GIS) is a system designed to enable people to
work with data related to places on the Earth. A GIS allows the creation, storage,
manipulation, and analysis of geographic data. GIS is a very broad concept and
can involve complex hardware and software. But for most people’s purposes, a
simple GIS software application is all that is required
GIS in general can be used for a variety of fields, including in disaster
management. Unfortunately, the GIS software currently on the market are very
expensive. Therefore we make a guide how to analyze the data with GIS software,
which is free and open for the purposes of disaster management, particularly in
the preparation of contingency plans.
The software used is QGIS (QGIS) is a Geographic Information System (GIS)
that is user-friendly and open-source. InaSAFE is a free software and opensource, that can create realistic scenario of natural disasters impact for planning,
preparation, and better response. InaSAFE is developed by AIFDR through
consultation with BNPB.
Analyzing Data with QGIS and InaSAFE is designed to complement the previous
unit to collect spatial data with OpenStreetMap for scenario development for
contingency plan.

We hope it can be useful.
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Module 1
GIS for Developing Contingency Plan

Learning Objectives
●

Distinguishing data and information

●

Understand the concept of GIS

The difference between data and information
In the first unit, we looked at OpenStreetMap and how to collect data and add it to the
worldwide map. But what do we mean when we say that we collect data? Is this the
same as collecting information? Well, not exactly.
Data is raw facts. Information is data that is organized and presented in such a way as to
be useful. In other words, when we go mapping to collect locations and facts about those
locations, we have collected data - we have collected facts. To turn this data into
information, we must make sense of it. We must present the data in such a way that it can
be easily understood.
OpenStreetMap data is already made informative in an obvious way. The map that you
see when you visit the OSM website is there because a computer has processed all of the
OSM data and used it to paint a nice looking map. The map is informative, and useful for
us to see where places are in relation to us.
In this unit we will take this even further. We will learn how to perform geographic data
analysis, and thereby learn how to make our data more useful, informative, and effective.

Terminology of Geographic Information System (GIS)
A Geographic Information System (GIS) is a system designed to enable people to work
with data related to places on the Earth. A GIS allows the creation, storage, manipulation,
and analysis of geographic data. GIS is a very broad concept and can involve complex
hardware and software. But for most people’s purposes, a simple GIS software
application is all that is required, and in this unit we will learn how to use the excellent
open-source application, QGIS.
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GIS provides different ways to analyze data. It enables us to ask complex questions, such
as:
●

where are all schools with more than 100 students?

●

how many children live in a certain district?

●

How many women live within 500 meters of a certain hospital?

●

What is the shortest walking path from a given point to a hospital?

GIS helps us to answer these sorts of questions. In the previous unit we learned how to
collect data, and in this unit we will see how to analyze it.
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Module 2
QGIS and InaSAFE in Contingency
Plan

Learning Objective
●

Explain GIS to prepare contingency plan

●

Explain the important of data

●

Explain the benefit QGIS/InaSAFE in the development of scenario for contingency plan

GIS for Preparing Contingency Plans
GIS has an important role in contingency planning. A contingency plan is intended to
support community preparedness to anticipate the arrival of a potentially hazardous event,
such as an earthquake or tsunami. The purpose of such a plan is to minimize casualties
and losses in case of such an event.
Before contemplating a contingency plan, one must first consider potential disaster
scenarios. A good plan will likely answer questions such as:
●

what sort of disaster would be likely to happen?

●

how widespread will the impact be?

●

who is responsible for helping?

●

what can be given as aid?

●

where are the priority areas?

In other words, a contingency plan answers the question, who does what, where and
when?
A Geographic Information System is able to help planners answer these questions,
especially the important spatial elements of contingency planning. GIS may be used to
model hazardous events so that they can be better predicted and reduce risk. It may be
used to plan evacuation routes prior to a disaster. When a disaster occurs, GIS may also
play a role in the emergency response phase. It can be used to map the area affected and
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position of refugee camps, so that helpers can be directed to the most useful locations to
aid those affected. After a disaster, GIS may also be used to plan for rehabilitation and
reconstruction. Overall, GIS helps to perform analysis of a disaster, damage and losses
caused, and opportunities for reducing risk.

The Importance of Data
We previously learned how to start collecting exposure data. When thinking about GIS it
is important to remember that if your data is bad, your analysis will be bad also. Hence
the more detailed and accurate your data is, the better your analysis and action may be
during a disaster.
As we shall see in this unit, some data may be obtained from various agencies that
specialize in certain kinds of data. For example, we will obtain our hazard models
(hazard data) from various organizations that specialize in this. As for exposure data,
some data we may find through agencies, such as population data. For ever important
infrastructure data, collecting data at a community level is key, which is why in the
previous unit we learned how to utilize the crowd-sourced OpenStreetMap platform.

QGIS and InaSAFE
QGIS (QGIS) is a user friendly open-source Geographic Information System (GIS). It
runs on Windows, Mac OSX, and Linux. QGIS provides a continually growing number
of capabilities provided by core functions and plugins. You can visualize, manage, edit,
analyze data, and compose printable maps.
QGIS is awesome because:
●

It’s completely free. It doesn’t cost anything.

●

It’s free, as in liberty. If you think a feature is missing, you can sponsor the development
of a feature, or add it yourself if you are familiar with programming.

●

It’s constantly developing and improving. Because many people continue adding
features, it keeps getting better.

●

Extensive help and documentation is available. If you have problems you can always
turn to the software documentation, other QGIS users, or even the developers.
QGIS has many plugins which extend the core functionality of the software. One of
these plugins is InaSAFE, which can be used to analyze the impact of a disaster and
create a list of actions needed to be taken when a disaster occurs. QGIS and InaSAFE
can also help to determine the location of ideal places of refuge, evacuation routes, areas
likely to be damaged, and more.
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InaSAFE provides overviews of potential disaster scenarios, of their outcomes, as well as
maps which can aid decision makers when disaster strikes. Maps are an effective way of
communicating disaster impact, but showing in a simple way the areas of damage, such
as the extent of flood-affected areas and buildings affected by a flood.
In the preface to this guide you may have followed along in our optional quickstart guide
to using InaSAFE. If you followed the steps in this chapter, then you have already
installed QGIS and InaSAFE and seen them in action. If you haven’t, don’t worry, we’ll
go through the steps again in this unit.
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Module 3
The Basics of QGIS

Learning Objectives
●

Downloading QGIS

●

Install QGIS

●

Open a previously created QGIS project

●

Looking at available layer list

●

Access basic tools through ‘toolbar’

●

Cleaning the toolbar

●

Displaying a map from window map

●

Getting information from map through status bar

In this chapter, we will get started using QGIS (QGIS). You’ll see how to install the
software (if you haven’t already), understand the layout and interface, and other core
functions of the software. By the end of this chapter, you’ll be on your way to becoming
a competent GIS user!
Note that if you followed along with the instructions in the introduction to this guide, you
may have already installed QGIS and InaSAFE. If so, feel free to skip ahead to section
three in this chapter. Otherwise, let’s start here and get QGIS installed.
1. Get QGIS
●

The QGIS installer is contained in the file package that comes with this guide, in
software/QGIS-OSGeo4W-2.0.x-2-Setup.exe. If you have this file, skip to section 2.
Otherwise you can download it from the QGIS website.

●

Open your web browser and in the address bar at the top of the window, type qgis.org.
Press enter.
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●

The QGIS website will look something like this:

●

Click ‘Download Now!”

●

If you are using Windows click on QGIS Standalone Installer Version 2.0.1 (32 bit)

●

If you are not using Windows, select your Operating System from the menu.
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●

When the file is downloaded, run it and follow the instructions to install QGIS.

2. Install QGIS
●

Open the folder where you have the QGIS installation file.

●

Run the installation file. If you are installing QGIS version 2.0.x, it should look like this:
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●

Click Next.

●

Click “I Agree” to agree with the conditions in the license agreement.
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●

The next window asks where you would like to install QGIS. In most cases, the default
should be fine. Click Next.

●

In the next window, Click “Install” without checking any of the boxes.
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●

QGIS will begin to install. It may take a few minutes to complete.

●

Click “Finish” to complete the installation. Then your computer will automatically
reboot.
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●

You can now open QGIS from your Desktop, click QGIS 2.0.1 Desktop shortcut.

●

QGIS will look something like this:

3. QGIS user interface layout
In this section we will open up a QGIS project, and take a look at the different pieces of
the QGIS interface. If you installed InaSAFE previously, make sure it is closed by
clicking on the X in the upper right corner of the InaSAFE panel. If it isn’t open or you
haven’t installed it yet, carry on. We will come back to this later.
●

Click on the folder icon on the upper toolbar or go to File ‣ Open Project...
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●

Navigate to the tutorial files and go into the qgis/ directory. Open the file named
sleman_2_2.qgs.

●

QGIS should now look something like the following image. Let’s pause for a moment
and go over the various components of the QGIS interface.

Map Canvas
This is the window where the map is shown. Our project has two different files open, one
which shows districts of the Sleman regency, and another that shows the railway line
running through the area. You can see both of these files are drawn together in the map
canvas.
Layers List
On the left side of QGIS is the layers list. This lists the layers, or files, that are loaded
into our QGIS project. In this project, we have two layers, Kecamatan_Sleman and
railway_Sleman_OSM. The layers panel not only shows all the files that are currently
open, it also determines the order that they will be drawn on the map canvas. A layer that
is at the bottom of the list will be drawn first, and any layers above it will be drawn on
top.
●

Click on the layer railway_Sleman_OSM and drag it below the layer named
Kecamatan_Sleman.
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●

Notice how the map canvas changes. The railway layer is now shown below the district
layer, and part of the railway is now obscured. A map will never show railway hidden
beneath district areas, so go ahead and move the layers back.

●

Uncheck the box next to a layer’s name. It will be hidden from the map canvas.

●

You can expand collapsed items by clicking the arrow or plus symbol beside them. This
will provide you with more information on the layer’s current appearance.

●

Right-click on a layer to view a menu with menu extra options. You’ll be using some of
them before long, so take a look around!
Toolbars
At the top of QGIS are a large number of tools, which are contained within various
“toolbars.” For example, the File toolbar allows you to save, load, print, and start a new
project. We already used one of these tools when we opened this project.

●

By hovering your mouse over an icon, the name of the tool will appear to help you
identify each tool.

●

The number of tools (buttons) can seem a bit overwhelming at first, but you will
gradually get to know them. The tools are grouped into related functions on toolbars. If
you look closed you can see a vertical array of ten dots to the left of each toolbar. If you
grab these with your mouse, you can move the toolbar to a more convenient location, or
separate it so that it sits on its own.
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●

If you feel overwhelmed by the number of toolbars, you can customize the interface to
see only the tools you use most often, adding or removing toolbars as necessary. To add
or remove a toolbar, right-click on any of the toolbars, or go to View ‣ Toolbars.

●

Let’s remove some of the toolbars that we will not be using in this training, to make the
interface a bit cleaner. Right-click on the toolbar, and uncheck the boxes next to the
following toolbars:
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○

Advanced Digitizing

○

Database

○

GRASS

○

Label

○

Raster

○

Vector

●

After removing these toolbars and moving them around, your tools should look like this:

Even if they are not visible in a toolbar, all of your tools will remain accessible via the
menus. For example, if you remove the File toolbar (which contains the Save button), you
can still save your map by clicking on the File menu and then clicking on Save.
Status Bar
This shows information about the current map. It allows you to adjust the map scale and
see the mouse cursor’s coordinates on the map.

The coordinates of this map are the same type of coordinates that you learned about when
learning about GPS devices. The status bar show shows the longitude and latitude of
your mouse cursor.
This may not all be clear right now, but as you progress in your knowledge of GIS is will
make more and more sense.

4. Adding Vector Layer
Now we will add an additional layer containing roads to our project.
●

Click on the “Add Vector Layer” button on the toolbar.

●

A dialog box will open. Click the “Browse” button.
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●

Navigate to the file qgis/Sleman/Jalan_Sleman_OSM.shp (in the training directory).
Select the file and click Open.

NOTE: One of the most common file formats are
shapefiles, which end with the extension .shp.
Shapefiles are often used to save geodata, and are
commonly used with GIS applications like QGIS.

●

You should now see your new layer appear both in the map canvas and in the layers list.
It should be drawn above both the district and railway layers.

5. Basic QGIS Tools
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We’ve already taken a look at the QGIS toolbar and seen the tools for opening a project
and adding a new layer. Here’s a list of some other commonly used tools. Feel free to
play around with them if you like. The important thing for now is to start getting familiar
with QGIS.

Toggle Editing

Edit features in a layer

Pan Map

Drag the map to a new location

Zoom In

Zoom in on the map

Zoom Out

Zoom out on the map

Zoom Full

Zoom so that all layers fit in the map window

Open Attribute Table

Open a layer’s attribute table

Select Single Feature

Select a feature in the selected layer

6. Panning Map
●

Before we examine the attributes of individual features, let’s take a quick look at how to
navigate the map. The main controls for moving the map around and zooming in and out
are by default on the panels at the top of QGIS.

●

When you click on one of these buttons, it changes what you can do with your mouse in
the main map window.

●

Select the first button that looks like a hand. Now hold your left mouse button down and
drag your mouse in the map window. This allows you to pan the map, or move it around.
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●

The button which has a plus sign below a magnifying glass, allows you to zoom in on the
map. Select this button. Using your mouse, draw a box around an area that you want to
zoom in on, and release your mouse.

●

The button which has a minus sign below a magnifying glass, allows you to zoom out on
the map. Select this button and click on the map. This allows you to zoom out.

●

The button that looks like a magnifying glass with red arrows pointing away from it lets
you zoom to the full extent of your map. When you click this button, you will be able to
see all of the data that you have loaded in your project fit into the map canvas.
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Module 4
QGIS Plugins

Learning Objectives
●

Understand the Concept of Plugins

●

Install QGIS Plugins

●

Add satellite imagery via OpenLayers

●

Install InaSAFE Plugin

QGIS has core functionality, which we will continue to explore in this guide, but it also
allows the use of additional plugins, which allow you to add functionality to the
software. Again, these plugins are free. To use them, you simply need to connect to the
internet and install. In this chapter we will learn how to install QGIS plugins, using one
plugin to add a satellite imagery layer to our QGIS project.
If you have closed QGIS since completing the previous chapter, start it again and open up
the project that you saved at the end of the chapter. If you didn’t save where we left off,
don’t worry, simply open the project named sleman_2_3.qgs in the qgis/ folder.
Note that you must be connected to the internet to follow the exercises in this chapter.

1. Managing Plugins
To install new plugins, make sure you are connected to the internet. They first need to be
downloaded, and then activated. Some plugins are already downloaded and available,
and you can see them by going to Plugins ‣ Manage and Install Plugins.

The Installed tab displays a list of plugins that have already been downloaded and can be
activated. To enable a plugin, check the box next to it in this menu and press Close. For
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now, let’s leave all the plugins as they are. We’re going to download and activate a new
plugin in the next section.

2. Installing Plugins
There are many more plugins, but they must first be downloaded. To download a plugin,
go to ‘New’. This will load available plugin repositories, and you will see a list of all
available plugins for download.
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Note that plugins which have already been downloaded can be activated or deactivated
from the “Installed” menu. If it has not yet been downloaded, downloading a plugin from
the “New” menu will automatically activate it.

3. The OpenLayers Plugin
The OpenLayers plugin allows you to view various web maps as a layer in QGIS. This
means that you can access the OSM slippy map, Google Maps, and Bing maps, from
within QGIS. Follow along and we’ll see what this means.
●

Go to Plugins ‣ Manage and Install Plugins… ‣ New and type “openlayers” into the
search box.
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●

Select “OpenLayers Plugin” from the list and click “Install plugin.”

●

It may take a few minutes to download.

●

When the download finishes click OK.
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●

Now the OpenLayers plugin is installed and activated. If you go Installed you will see it
now in your list of active plugins. Click close after you finished.

●

Now we have new menus options that offer extra functionality. Go to Plugins ‣
OpenLayers plugin and you will see various options of map layers that you can load.
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●

Click on “Bing Aerial layer.” A new layer, called “Bing Aerial” will be added to your
layers list, and the imagery will load on your map canvas. If the layer is above your other
layers, drag it to the bottom of the layers list.

●

Your project should now look like this:
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●

If you pay attention, there is something wrong with the maps. Can you guess what is it?
All three layers above Bing Aerial layers should be shown on the map. It is not shown
because of Rendering Order setting on Layer Order Panel. To fix this, go to View 
Panel  Activate Layer order panel
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●

Then, Layer order panel will shows next to Layers panel (1). Click that panel and
Uncheck Control Rendering Order to fix the problem (2)
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●

Then back to Layers panel, and you can see the map should shows in correct order. All
layers above Bing Aerial will shows up on the map canvas like image below.
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●

Adding a layer such as Bing Aerial Imagery will change the Coordinate Reference
System, or CRS, of your project. Essentially this means that your project is not using
longitude and latitude coordinates anymore. This shouldn’t affect you right now, but it
will make sense later when we cover CRSes.

●

If the map data does not appear to match up with the aerial imagery, it may be due to
different CRSes. You can fix this problem by going to Project  Project Properties, then
go to CRS tab and checking the box next to “Enable ‘on the fly’ CRS Transformation.”
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●

Cool! Now we can see our map data on top of an aerial photograph of the earth! Note
that this is the same imagery provided by Microsoft Bing that you would load for editing
in JOSM. Try unchecking the box next to the layer Kecamatan_Sleman so that you can
see the area better. If you zoom in close you can see detailed imagery with our streets
and railway layers displayed on top.

●

Remove the Bing Aerial layer by right-clicking it in the layers list and selecting
“Remove.”

●

Try out other layers that are available to you from the Plugins ‣ OpenLayers plugin
menu.
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4. Install InaSAFE Plugin
Now, we are going to install InaSAFE plugin.


Go to ‘Plugins  Manage and install plugins’ menu



Go to the ‘New’ tab and type “inasafe” on the search box



Select InaSAFE and click ‘Install plugin’ and wait for a moment until a popup notification showing that plugin has installed successfully.



Close the plugin manager window and we will learn about InaSAFE later in
Module 12.

Module 5
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Map Projection Basics

Learning Objectives
●

Understand Coordinate Reference Systems (CRS)

●

Identify the CRS of a vector dataset

●

Doing “on the fly” reprojection

●

Save dataset with a different CRS

●

Making its own projection

We’ve talked a little bit about Coordinate Reference Systems (CRSs) previously, but
haven’t covered it in depth. In this chapter, we’ll look more at what a CRS means
practically, and how it affects our work in QGIS.

1. Coordinate Reference System (CRS)
The CRS that all the data as well as the map itself are in right now is called WGS84. This
is a very common Geographic Coordinate System (GCS) for representing data. But
there’s a problem, as we will see.
●

Open the project world.qgs, located in the qgis/ folder

●

Zoom in to Indonesia by using the Zoom In tool.

●

Setting the scale in the Scale field, which is in the Status Bar along the bottom of the
screen. While over Indonesia, set this value to 1:20000000 (one to twenty million).

●

Now pan around the map while keeping an eye on the Scale field.
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Notice the scale changing? That’s because you’re moving away from the one point that
you zoomed into at 1:20000000, which was at the center of your screen. All around that
point, the scale is different.
To understand why, think about a globe of the Earth. It has lines running along it from
North to South. These longitude lines are far apart at the equator, but they meet at the
poles. In a GCS, you’re working on this sphere, but your screen is flat. When you try to
represent the sphere of the earth on a flat surface, it becomes distorted, as if you took an
orange peel and tried to flatten it. What this means on a map is that the longitude lines
stay equally far apart from each other, even at the poles (where they are supposed to
meet). This means that, as you travel away from the equator on your map, the scale of the
objects that you see gets larger and larger. What this means for us, practically, is that there
is no constant scale on our map!
To solve this, we’ll use a Projected Coordinate System (PCS) instead. A PCS “projects”
or converts the data in a way that makes allowance for the scale change and corrects it.
Therefore, to keep the scale constant, we should reproject our data to use a PCS.

Projection is the act of taking coordinates on a sphere
(like the earth), and manipulating them so that they can be
displayed on a flat surface.

2. “On the Fly” Reprojection
Every QGIS project has a CRS, and each of the data layers have a CRS too. Often these
are the same. Your project may be in WGS84, and the layers too. But sometimes you
will add a layer that is not in the same CRS as the project, and you need QGIS to convert
it so that it can be displayed along with the rest of the data. The term that we use for this
is reprojecting “on the fly.
●

To enable “on the fly” projection, click on the CRS Status button in the Status Bar along
the bottom of the QGIS window:

●

In the dialog that appears, check the box next to Enable ‘on the fly’ CRS transformation.

●

Type the ‘NSIDC’ into the Filter field. One CRS (NSIDC EASE-Grid Global) will appear
in the list below.
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●

Click on it to select it, then click OK.

●

Notice how the shape of Indonesia changes. All projections work by changing the
apparent shapes of objects on Earth.

●

Zoom in to a scale of 1:20000000 again, as before.

●

Pan around the map.

●

Notice how the scale stays the same!

“On the fly” reprojection is useful for combining datasets that are in different CRSes.
●

Deactivate “on the fly” reprojection again, by unchecking the box next to Enable ‘on the
fly’ CRS transformation.

●

Now let’s add another vector layer, located in qgis/peta_dunia/Indonesia.shp.

What do you notice? The layer isn’t visible! But that’s easy to fix, right?
●

Right-click on the layer in the Layers list.

●

Select Zoom to Layer Extent.
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OK, so now we see Indonesia... but where is the rest of the world?
It turns out that we can zoom between these two layers, but we can’t ever see them at the
same time. That’s because their Coordinate Reference Systems are so different. The
continents layer is in degrees, but the Indonesia layer is in meters. In other words, one
feature in the continents layer might be 8.5 degrees away from the equator, but the same
feature in the Indonesia layer might be 900000 meters away from the equator.
8.5 degrees and 900000 meters is about the same distance, but QGIS doesn’t know that!
One of our layers must be reprojected to match the other layer.
To correct this:
●

Switch Enable ‘on the fly’ CRS transformation on again as before.

●

Zoom to the extents of the Indonesia dataset.
Now, because they’re made to project in the same CRS, the two datasets fit perfectly:

When combining data from different sources, it’s important to remember that they might
not be in the same CRS. “On the fly” reprojection helps you to display them together.

3. Dataset with different CRS
It’s great that QGIS can reproject layers on the fly so that we can work with them in the
same project. But this requires more time for our computer to reproject the layers, and
can slow down our work. For this, or for other reasons, we might want to be able to
reproject a dataset, and save it with the new projection.
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Let’s reproject the Indonesia layer so that it is in the same CRS as the project. To do this,
we will need to export the data to a new file using a new projection.
●

Right-click on the Indonesia layer in the Layers list.

●

Select Save As... in the menu that appears. You will be shown the Save vector layer as...
dialog.

●

Click on the Browse button next to the Save as field.

●

Navigate to qgis/peta_dunia/ and specify the name of the new layer as
Indonesia_terproyeksi.shp.

●

Leave the Encoding unchanged.

●

Change the value of the Layer CRS dropdown to Project CRS.

●

Check the box next to “Add saved file to map.”

●

The Save vector layer as... dialog now looks like this:

Unit 2: QGIS and InaSAFE Beginner Level | 43

●

Click OK and after a minute, you should be presented with a notification above map
canvas telling that the process is finished.

●

Now your new layer, Indonesia_terproyeksi, will be shown in the layers panel. If you
turn off “on the fly” reprojection, this layer will still be shown correctly, because it has
been reprojected into the same CRS as the project (and the continents layer).
4. Creating Your Own Projection
There are many more projections than just those included in QGIS by default. You can
even create your own projections. Let’s see how this works.

●

Start a new map.

●

Load the vector layer oceans.shp located in qgis/peta_dunia/.

●

Go to Settings ‣ Custom CRS... and you’ll see this dialog:
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●

We will create a projection known as Van der Grinten I. This interesting projection
represents the Earth on a circular field instead of a rectangular field, as most projections
do.

●

Enter “Van der Grinten I” in the Name field.

●

In the Parameters field, use the following string:
+proj=vandg +lon_0=0 +x_0=0 +y_0=0 +R_A +a=6371000 +b=6371000 +units=m
+no_defs
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●

Click OK.

●

Go to Project  Project Properties

●

Enable “on the fly” reprojection.

●

Search for your newly defined projection by typing it into the Filter box:

●

You should see it appear in the box at the bottom. Select it, and click OK.

●

Once you’ve applied the new projection, the map will be reprojected like this:
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Module 6
Working with Vector Data

Learning Objectives
●

Understand vector data

●

Identify attribute of vector data

●

Add vector layers

●

Symbolize vector layers
In this chapter, we will learn what is meant by vector data. We will practice adding it to
our QGIS projects, and we will learn how to style the data in different ways.

1. Vector Data
Vector data is the most common type of data found in GIS. A vector is essentially
something in the form of a dots, or lines connecting those dots. In other words, points,
lines, and polygons are all vectors. (curved lines are vectors too, but we won’t worry
about that for now) We are already quite familiar with vector data because in the
previous unit, we used JOSM to create it!
Each object in a vector dataset is referred to as a ‘feature.’ When we are using JOSM we
often refer to them as objects, but in traditional GIS terminology they are features. A
polygon that represents a building is a feature, as is a line that represents a river. Each
feature has a geographic location, and is attached to other data that describe the feature.
One important thing to note is that QGIS layers can only contain one type of feature.
That is, one layer can’t contain both point features and line features, because they are
different types of data. Hence if you have a file that contains school polygons and
another file that contains school points, you would add them as two separate layers.
Almost always, polygon layers will be at the bottom of your layer list, line layers in the
middle, and point layers at the top. You don’t generally want your polygons overlapping
your lines and points.
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2. Attribute Data
It’s important to know that the data you will be working with does not only represent
where objects are in space, but also tells you what those objects are.
●

Open the project sleman_2_5.qgs. This is the same project that you worked with in
chapter 3.

●

Close the InaSAFE panel if you still have it open.

●

You can see in your project the position of Sleman districts, the railway, and some roads,
but you can’t see all of the data contained in those layers.

●

Select Jalan_Sleman_OSM in the layers list.

●

Click the “Open Attribute Table” button:

●

You will see a table with more data about the streets layer. This extra data is called
attribute data. The lines that you can see on your map represent where the streets go this is the spatial data. You will remember in JOSM that there was the same division.
The points, lines, and shapes you drew tell us where, but the tags, or attributes, tell us
what. These definitions are commonly used in GIS, so it’s essential to remember them!

●

Take a look at the attribute table. Each row in the table is associated with one feature in
the streets layer. Each column contains one of the attributes. If you select other layers
and click on the “Open Attribute Table” button, you’ll see different tables.

●

Close the attribute table.
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3. Adding Vector Data
Shapefiles
You’ve already added vector data to a project once, in the form of a shapefile. As we
mentioned previously, a shapefile is a commonly used geographic file format. It can
easily be converted into other formats, and most GIS software can read this type of file.
You may notice when adding a shapefile that there are numerous files in your shapefile
directory with the same name. This is because a shapefile actually relies on a collection
of several other files to store the data and keep various settings. When you add a
shapefile to your project, you should always add the one that ends in .shp, but the rest of
the files are important too!
●

Do you remember how to add a shapefile? Try adding the layer POI_Sleman_OSM,
from the shapefile located in the tutorial directory. If you don’t remember how to add a
new vector layer, refer to the instructions in chapter 2.

●

Your project should look like this after the new layer has been added:

Databases
Shapefiles (and other types of files) are one way to store geographic data. You can also
load a vector layer into QGIS from a database. You may already be familiar with
Database Management Systems (DBMS) such as Microsoft Access. GIS applications
also make use of databases to store geographic data. Databases can be hosted and used
locally on your computer, or could be shared between users over a network or even the
internet..
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●

Let’s try adding a layer from a database. Click on the following icon. If you can’t find it,
right-click on the toolbar and make sure that the “Manage Layers” toolbar is enabled.

●

You will see a dialog box. Click “New.”

●

Navigate to the qgis_data/Sleman folder and find the file guna_lahan.db. Select the file
and click “Open.”

●

Now in the original dialog box, you will see that the dropdown button now contains
“guna_lahan.db @ ...”, followed by the path of the database file on your computer.

●

Click “Connect.” You will see the following in the box:
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●

This database actually has three different layers available, all saved in the database. Click
on the first layer to select it, then hold SHIFT and click the last layer to select them all.

●

Click “Add.” This will add all three layers to our project.

NOTE: Remember frequently to save your map! Your QGIS
project file does not save the data (data is saved in a
shapefile or a database), but it does remember the layers
that you have added to the project, their order, and any
settings that you adjust.
●

The layers you have just added are all polygon layers, so you will want to drag them
down below the line and point layers. If you have a checkbox beneath your layers list
that reads “Control rendering order,” go ahead and check it.

●

Let’s remove a couple of layers to make it easier to deal with our data. Right-click on the
railway and district layers and click “Remove.” Then order your layers like this:
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4. Symbology
The symbology of a layer is its visual appearance on the map. One of the basic strengths
of GIS is that you have a dynamic visual representation of the data you’re working with.
Therefore, the visual appearance of the map (which depends on the symbology of the
individual layers) is very important. The end user of the maps you produce will need to
be able to easily see what the map represents. Equally as important, you need to be able
to explore the data as you’re working with it, and good symbology helps a lot.
In other words, having proper symbology is not a luxury or just nice to have. In fact, it’s
essential for you to use a GIS properly and produce maps and information that people
will understand and be able to use.
4.1 Changing colors
To change a layer’s symbology, we will open its Layer Properties. Let’s begin by
changing the color of the pemukiman layer.
●

Right-click on the pemukiman layer in the Layers list.

●

Select the menu item Properties in the menu that appears.
Note: By default you can also access the Properties menu by
double-clicking on the name of the layer.

●

In the Properties window select the “Style” tab.
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●

Click the color button to change the color

●

A standard color dialog will appear. Choose a grey color and click OK.
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●

Click OK again in the Layer Properties window, and you will see the color change being
applied to the layer.

4.2 Changing Symbol Structure
This is good stuff so far, but there’s more to a layer’s symbology than just its color. Next
we want to change the color of the vegetation, but we also want to eliminate the lines
between the different types of vegetation so as to make the map less visually cluttered.
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●

Open the Layer Properties window for the vegetasi layer. Under the Style tab, you will
see the same kind of dialog as before. This time, however, we will do more than just
change the color.

●

Click on the Simple Fill under the symbol layer column panel. Then Symbol layer dialog
will appear next to the symbol layer column panel.

●

Change the color inside the polygons in the layer by clicking the button next to the Fill
label:
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●

In the dialog that appears, choose a new color (that seems to suit vegetation).

●

Click OK.

●

Next, we want to get rid of the lines between all the farms.

●

Click on the Border style dropdown. At the moment, it should be showing a short line and
the words Solid Line.

●

Change this to No Pen.

●

Click OK, and then OK again. Now when we look at our map, the vegetasi layer will
have a new color and no lines between polygons.

●

Try changing the symbology of the pemukiman layer so that it also does not have
outlines.

4.3 Scale-based Visibility
Sometimes you will find that one of your layers is not suitable for a given scale. For
example, if you have a layer which shows the earth’s continents but not with very much
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detail, the continent lines may not be very accurate when you are zoomed in very far to
see streets.
Note: Scale is a reference to how your map references what
is actually on the ground in terms of size. Scale is
usually given in terms like 1:10000, which means that one
centimeter of length on your map is equal to 10000
centimeters in the real world. When you zoom in or out on
a map, the scale changes, as you can see in the status bar
at the bottom of QGIS.
In our case, we may decide to hide our streets layer when we are zoomed out very far (a
small scale). For example, the streets layer is not very useful when we are zoomed out
far and it looks like a blob.

Let’s enable scale-based rendering:
●

Open the Layer Properties dialog for the Jalan_Sleman_OSM layer.

●

Activate the General tab.

●

Enable scale-based rendering by clicking on the checkbox labeled “Scale dependent
visibility.” Then change the value in “Maximum” to 1:10 and “Minimum” to 1:100000

●

Click OK.

Unit 2: QGIS and InaSAFE Beginner Level | 58

●

Now look at your map and see what happens when you zoom in and out. The streets
layer should appear when you are at a large scale and disappear at small scales.
NOTE: You can use your mouse wheel to zoom in increments.
Alternatively, use the zoom tools to draw a box and zoom to
it:

4.4 Adding Symbol Layers
Now that you know how to change simple symbology for layers, the next step is to create
more complex symbology. QGIS allows you to do this using symbol layers.
●

Go back to the vegetasi layer’s Symbol properties dialog as before.

●

In this example, the current symbol has no outline (i.e., it uses the No Pen border style).

●

Click on “Fill” then click + button on the left.
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●

Click on it and another symbol layer will be added to the list:

●

Note that it may appear different in color, but we’re going to change that anyway.

Now this layer has two different symbologies. In other words, both the green color AND
the blue color will be drawn. However, the blue color will be drawn above the green, and
since it is a solid color, it will completely hide the green color. Let’s change it.
It’s important not to get confused between a map layer and a symbol layer. A map layer is
a vector (or raster) that has been loaded into the map. A symbol layer is part of the
symbol used to represent a map layer. This course will usually refer to a map layer as just
a layer, but a symbol layer will always be called a symbol layer, to prevent confusion.
●

Set the border style to No Pen, as before.

●

Change the fill style to something other than Solid or No brush. For example:
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●

Click OK and then OK and take a look at your layers new symbology.

●

Now try it yourself. Add an additional symbology layer to the Jalan_Sleman_OSM
layer.

○

Give the thickness of the original layer a value of 2.0
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○

Give the thickness of the new symbology layer a value of 1.0

●

This will result in your roads looking something like this:

●

Our streets now appear to have an outline, but they seem disjointed, as if they don’t
connect with each other. To prevent this from happening, you can enable symbol levels,
which will control the order in which the different symbol layers are rendered.

●

In the Layer Properties dialog, click on Advanced ‣ Symbol levels:

●

The Symbol Levels dialog will appear. Check the box next to “Enable symbol levels.”

●

Your map will now look like this:
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●

When you’re done, you can save the symbol itself in QGIS so that you won’t have to do
all this work again if you want to use the symbol again in the future. Save your current
symbol style by clicking the Save Style ... button under the Style tab of the Layer
Properties dialog.

●

Give your style file a name and save. You can load a previously saved style at any time by
clicking the Load Style ... button. Before you change a style, keep in mind that any
unsaved style you are replacing will be lost.

●

Try to change the appearance of the streets layer again, so that the roads are dark gray or
black, with a thin yellow outline, and a dashed white line running in the middle.

4.5 Classified Symbology
Symbol levels also work for classified layers (i.e., layers having multiple symbols). We
will cover classification in the next chapter, but you can see how it works here with roads.
By classifying various streets according to their type, we can give them different
symbologies and they will still appear to flow into each other.
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4.6 Symbol layer types
In addition to setting fill colors and using predefined patterns, you can use different
symbol layer types entirely. The only type we’ve been using up to now was the Simple
Fill type. The more advanced symbol layer types allow you to customize your symbols
even further.
Each type of vector (point, line and polygon) has its own set of symbol layer types. First
we will look at the types available for points.

Vector Points
●

Change the symbol properties for the POI_Sleman_OSM layer:
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●

You can access the various symbol layer types by clicking a symbol layer (1) then
clicking the dropdown box in the upper right corner (2)

●

Investigate the various options available to you, and choose a symbol layer type other
than the default Simple Marker.
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●

If in doubt, use an Ellipse Marker.

●

Choose a white outline and dark fill, with a symbol width of 2.00 and symbol height of
4.00.

Vector Lines
●

To see the various symbology options for vector lines, open the streets layer properties
and click on the dropdown box:
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●

Click on “Marker line.”

●

Click Simple Marker on symbol layers (1)
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●

Change the symbol properties to match this dialog:
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●

Now, click on “Marker line” on symbol layers panel, then change the interval to 2.00:

●

Your road should now look something like this:

Once you have applied the style, take a look at its results on the map. If the dots not
shown up, check the advanced setting and go back to Symbol level. Change the upper
symbol layer to “2”. Then click OK. As you can see, these symbols change direction
along with the road but don’t always bend along with it. This is useful for some purposes,
but not for others. If you prefer, you can change the symbol layer in question back to the
way it was before.

Vector Polygons
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●

Now let’s change the symbol layer type for the pemukiman layer. Take a look at the
dropdown menu as you’ve done for the point and line layers, and see what the various
options can do.

●

Feel free to play around with the various options. We will use the Point pattern fill with
the following settings:
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●

Add a new symbol layer with a normal Simple fill.

●

Make it gray with no outlines.

●

Move it underneath the point pattern symbol layer with the Move down button:

●

The symbol properties should look like this:

Unit 2: QGIS and InaSAFE Beginner Level | 71

As a result, you have a textured symbol for the urban layer, with the added benefit that
you can change the size, shape and distance of the individual dots that make up the
texture.
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Module 7
Labels and Classification

Learning Objectives


Explores the attributes of data in objects and explain the use of varying

data types




Add labels to vector layers

Give a vector data label using classification

Up to now, none of the changes we have made to the map have been influenced by the
objects that are being shown. In other words, every type of vegetation looks alike, and all
the roads look alike. When looking at the map, the viewers don’t know anything about the
roads they are seeing; only that there is a road of a certain shape in a certain area.
But the whole strength of GIS is that all the objects that are visible on the map also have
attributes. Maps in a GIS aren’t just pictures. They represent not only objects in locations,
but also information about those objects. In this lesson we will explore the attribute data
of an object and understand what the various data can be useful for.
If you would like to start with the examples used in this chapter, begin by opening the
QGIS project sleman_2_6.qgs.
1. Attribute Data
●

Open the attribute table for the POI_Sleman_OSM layer by selecting it in the layers list
and clicking on the Open Attribute Table button (you can also right-click on the layer and
select Open Attribute Table).

●

Which field would be the most useful to use as a label?
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You now know how to use the attribute table to see what is actually in the data you’re
using. A dataset will only be useful to you if it has the attributes that you care about. If
you know which attributes you need, you can quickly decide if you’re able to use a given
dataset, or if you need to look for another one that has the required attribute data.
Different attributes are useful for different purposes. Some of them can be represented
directly as text for the map user to see. Next we’ll see how to use attributes as labels, so
that users can see the text on your map.

2. The Label Tool
Labels can be added to a map to show any information about an object. Any vector layer
can have labels associated with it. Labels rely on the attribute data of a layer for their
content.
There are several ways to add labels in QGIS, but some are better than others. You may
notice that when you open the Layer Properties window for a layer, there is a tab called
“Labels.” While this tab is designed to put labels on your map, it is not nearly as good as
the so-called “Label Tool,” which we will learn in this section.
Before being able to access the Label tool, you will need to ensure that it has been
activated.
●

Go to the menu item View ‣ Toolbars.
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●

Ensure that the Label item has a checkmark next to it. If it doesn’t, click on the Label
item, and it will be activated. The Label toolbar looks like this:

●

Click on the POI_Sleman_OSM layer in the Layers list, so that it is highlighted.

●

Click on the “Labelling” button:

This gives you the Layer labeling settings dialog.
●

Check the box next to Label this layer with....

●

We must indicate which of the attribute fields we want to use for the labels. The NAME
field is the mostly likely candidate for a label, so let’s select NAME from the list:

●

Click OK. The map should now have labels like this:
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What we have so far is good, but as you can see, the labels are overlapping the points that
they are associated with. That doesn’t look very nice. The text is also a bit larger than it
needs to be. Let’s fix these problems!
●

Open the Label tool again by clicking on its button as before.

●

Click on the Text tab button to change the text properties:



A standard text change dialog appears, similar to those in many other
programs. Change the font to Arial size 9

Now click on Buffer tab to add buffer on the text. Check box labelled
“Draw text buffer”
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Your labels will now look like this:

Now you can see why we usually need label buffers!
That’s the font problem solved! Now let’s look at the problem of the labels overlapping
the points.
●

In the Label tool dialog, click on “Distance” tab.

●

Change the value of Label distance to 2.
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●

Click OK. The labels no longer hover over the icons, but are “buffered” a short distance
away:

Labeling lines
Now that you know how labeling works, there’s an additional problem. Points and
polygons are easy to label, but what about lines? If you label them the same way as the
points, your results would look like this:
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This is not very useful! To make lines behave, we’ll need to edit some options.
●

Hide the POI_Sleman_OSM layer so that it doesn’t distract you.

●

Activate labels for the Jalan_Sleman_OSM layer as before. (Remember to use the Label
tool on the toolbar, not the one in Label Properties!)

●

Set the font Size to 9 and activate the buffer so that you can see more labels.

●

Zoom in so that the scale is around 1:10000.

●

In the Label tool dialog’s Placement tab, choose the following settings:
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The map will look somewhat like this, depending on scale:

It’s better than before, but still not ideal. For starters, some of the names appear more than
once, and that’s not always necessary. To prevent that from happening:
●

Go to “Rendering” tab

●

Enable the option Merge connected lines to avoid duplicate labels (also under the
Rendering tab - you may need to scroll down to see it).
Another useful function is to prevent labels being drawn for features too short to be of
notice.

●

Set the value of Suppress labeling of features smaller than ... to 5mm and note the results
when you click Apply.

●

Try out different Placement settings as well (also under the Placement tab). As we’ve
seen before, the horizontal option is not a good idea in this case, so let’s try the curved
option instead!

●

Select the curved option under the Placement tab of the Layer labeling settings dialog.
Here’s the result:
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As you can see, this hides a lot of the labels that were previously visible, because of the
difficulty of making some of them follow twisting street lines and still be legible. You can
decide which of these options to use, depending on what you think seems more useful or
what looks better.
Now that you know how attributes can make a visual difference for your map, how about
using them to change the symbology of objects themselves? That’s the topic for the next
section!
3. Classification
Labels are a good way to communicate information such as the names of individual
places, but they can’t be used for everything. For example, let’s say that we want to show
which district each feature in our vegetation layer is in. Using labels, it would look like
this:
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Obviously this is not ideal, so we need another solution. That’s what this lesson is about!
In this section, we will learn how to classify vector data effectively.
Classifying nominal data
●

Open Layer Properties for the vegetasi layer.

●

Go to the Style tab.

●

Click on the dropdown that says Single Symbol:

●

Change it to Categorized and the interface will change:
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●

Change the Column to guna_lahan and the Color ramp to Spectral:

●

Click the button labeled Classify:
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●

Click OK. You’ll see something like this:
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●

Click the arrow (or plus sign) next to rural in the Layer list, you’ll see the categories
explained:

So, this is useful! But it hurts your eyes to look at it, so let’s see what we can do about
that.
●

Open Layer Properties and go to the Style tab again.

●

Click the “Change” button next to Symbol.

●

Remove the outline as you did in the previous chapter. (change the border style to “No
Pen”)

●

Click the Delete all button:

●

Now click Classify again, and the new symbols will appear.
You’ll notice they don’t have outlines. This is because because you just removed the
outlines!

●

Change the color for each type of vegetation by double-clicking on the colored block next
to its name. You can change the color for each type of vegetation to something that you
think is more applicable, as we’ve done here:

●

Notice that the category on the bottom is empty. Select it, and click the Delete button.
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●

When we click OK our map looks like this:

If you feel confident in your new classification skills, try to classify the residential layer
yourself. Use darker colors to distinguish it from vegetation.
Ratio classification
In the previous example, we classified the vegetasi layer by what is known as nominal
classification. This type of classification is when categories are defined based on names.
Next we will classify the pemukiman layer based on the size of each feature.
Classifiying with attributes that contain only positive numbers, sych as land area, is
known as ratio classification.
●

Open the attribute table for the pemukiman layer. Notice the final column, luas_ha. This
attribute contains the size of the land area contained within that feature polygon.
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●

Open the layer properties for pemukiman.

●

Change the Style type to “Graduated,” and use luas_ha as the column.

●

Because we are categorizing with numbers this time, a color gradient will be useful for
representing our categories. Click on “Oranges” in the color ramp, and then click
Classify.
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●

Now you’ll have something like this:
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Module 8
Working with Raster Data

Learning Objectives


Creating Raster Data



Changing Raster Symbology



Doing Terrain Analysis

Thus far we’ve worked mostly with vector data, which consists of features, and these
features are themselves made up of points and lines. In this chapter we will learn about
raster data. Remember when you were editing OpenStreetMap in JOSM? The points,
lines and shapes that you drew were vector data. But when you loaded Bing aerial
imagery in the background, that was raster data. So what’s the difference?
Raster data essentially comes in the form of an image. It is made up of pixels, like a
photograph, and a raster image will always be some number of pixels wide and some
number of pixels high. If you zoom in far enough on a raster image, it will start to
become blurry, just as if you opened a photo on your computer and zoomed in very close.
As we’ll see in this chapter, however, a raster image can mean more than just a
photograph from the sky. Follow along and we’ll learn all about rasters!

1. Loading Raster Data
●

Open the project named sleman_2_7.qgs in the directory qgis/. We’ve simplified the
project since our last chapter, to make it easier to follow along, and so that our layers load
a bit faster. However, if you are comfortable you can easily carry on with your project
from the previous chapter.

●

Click on the Load Raster Layer button:

●

The Load Raster Layer dialog will open. Find the file in the directory Sleman/ named
Sleman.tif. Open it.

●

QGIS will open a dialog which explains that the new layers does not have a CRS
assigned. In the box at the bottom, scroll down until you find WGS 84 / UTM zone 49S.
Select it and click OK.
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●

When the raster layer loads, be sure to drag it to the bottom of your layers list.

●

If you can’t see the raster layer, you may need to enable “on the fly” transformations. To
do so:

●

Go to Project ‣ Project Properties...
Click CRS tab, then Enable “on the fly” reprojection.

●

Click OK.
Move Sleman.tif layer to the bottom then the raster should display nicely underneath
your vector data layers.
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2. How to Change Raster Symbology
Not all raster data consists of aerial photographs. There are many other forms of raster
data, and in many of those cases, it’s essential to symbolize the data properly so that it
becomes properly visible and useful. In this section we’ll add a new kind of raster and
see how to change it’s symbology.
●

First let’s remove our previous raster image so that our project will load faster. Rightclick on the Sleman layer and click “Remove.”

●

Click on the Load Raster Layer button:

●

Open the file named SRTM_Sleman.tif, which is located in Sleman/SRTM.

●

When it appears in the Layers list, right-click on it and click “Rename.” Give it the name
DEM.

NOTE: This dataset is a Digital Elevation Model (DEM). It’s
a map of the elevation (altitude) of the terrain, showing
us where the mountains and valleys are. In an aerial
photograph, each pixel in the image is a color. When we
view all of these different colored pixels together, they
show us something we can understand - the Earth as viewed
from above. In a DEM, each pixel has a different value
instead of color. The value of each pixel represents
elevation.

●

When it loads, you’ll notice that the new raster image appears as a gray rectangle. It’s
seen here with the roads layers on top:
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The layer appears gray (and doesn’t give us any information) because its symbology
hasn’t been customized yet. In the color aerial photograph we loaded previously,
everything is already defined. But if you load a raster image and it’s just a gray rectangle,
then you know there’s no symbology for it yet. It still needs to be defined. So that’s what
we will do now.
●

Open the Layer Properties dialog for the SRTM layer, which is now named DEM.

●

Switch to the Style tab. This shows the current symbology settings, and as we’ve seen,
they don’t give us much information on the layer. Let’s make sure the layer has data in it.

●

Change the render map to Single Pseudocolor, on Generate new color map column,
change into Spectral, activate “Reverse” mode, then click Classify. Our style setting
should be like:
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●

Klik OK. The raster should look like this:
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●

Good! This tells us that there is data in this layer. And by looking at it we can get an idea
of where the elevation gets higher. In the north we can see the location of Mount Merapi.

Let’s stop for a minute and understand what is happening here. Remember that an image
is made up of pixels, individual cells that contain a value, which is usually a color value.
For example, if you zoom in very closely on a photograph you can see those individual
pixels, like this:
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The value of each cell is saved in the file. Imagine the file being saved something like
this, where each square is a pixel::

Of course the computer doesn’t understand words for colors. In fact the value of each
cell would be a number, which the computer then associates with a certain color. For our
aerial image, this is already defined. Since it is a normal image, it knows to associate the
numbers for each pixel in the file with the common colors that we see every day. But this
new raster image is different, because the values of each pixel don’t represent colors, but
rather altitude, and QGIS doesn’t know automatically how to display it. Hence it shows
every pixel in the image as gray, even if the values in each pixel are different. When we
change the symbology to Psuedocolor, we can see all the different pixel values shown
with various colors.
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It would be nice to represent our DEM layer as a grayscale spectrum, rather than a variety
of bright colors.. Next we will tell QGIS to symbolize the layer with colors in a
spectrum, beginning at the lowest pixel value in the file and ending at the highest pixel
value. In other words, if the pixel values looked like this:

QGIS would create a spectrum equating numbers to colors like this:

And render the image like this:
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●

Open Layer Properties again.

●

Switch the render type back to Singleband Gray (1)

●

Tell it to use Custom min / max values (2)

●

Under Contrast enhancement, set the value of Current to “Stretch To MinMax” (3)
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But what are the minimum and maximum values that should be used? The ones that are
currently under Custom min / max values are the same values that just gave us a gray
rectangle before. Instead, we should be using the minimum and maximum pixel values
that are actually in the image. You can determine those values easily by loading the
minimum and maximum values of the raster.
●

Under Load min / max values from band, select Estimate (faster).

●

Click the Load button:

Notice how the Custom min / max values have changed. The lowest pixel value in this
image file is 0 and the highest is about 195.
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●

Click OK. You should see the values of the raster properly displayed, with the darker
colors representing valleys and the lighter ones, mountains:
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We’ve learned to do this the tricky way, but can we do it faster? Of course! Now that
you understand what needs to be done, you’ll be glad to know that there’s a tool for doing
all of this easily.
●

Remove the current DEM from the Layers list, by right-clicking and clicking “Remove.”

●

Load the raster image again, renaming it to DEM as before. It’s will be a gray rectangle
again.

●

Enable the tool you’ll need by enabling View ‣ Toolbars ‣ Raster. These icons will appear
in the interface:

The button on the right will stretch the minimum and maximum values to give you the
best contrast in the local area that you’re zoomed into. It’s useful for large datasets. The
button on the left will stretch the minimum and maximum values to constant values
across the whole image.

●

Click the button on the left (Stretch Histogram to Full Dataset). You’ll see the data is now
correctly represented as before! Easy!

3. Terrain Analysis
Certain types of rasters allow you to gain more insight into the terrain that they represent.
Digital Elevation Models (DEMs) are particularly useful in this regard. In this section
we’ll do a little bit more with our DEM raster, in order to try to extract even more
information from it.

3.1 Calculating a Hillshade
The DEM you have on your map right now does show you the elevation of the terrain,
but it can sometimes seem a little abstract. It contains all the 3D elevation information
about the terrain that you need, but it doesn’t really look 3-Dimensional. To get a better
look at the terrain, it is possible to calculate a hillshade, which is a raster that maps the
terrain using light and shadow to create a 3D-looking image.

To work with DEMs, you should use QGIS’ all-in-one DEM (Terrain models) analysis
tool.
●

Click on the menu item Raster ‣ Analysis ‣ DEM (Terrain models).
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●

In the dialog that appears, ensure that the Input file is the DEM layer.

●

Set the Output file to hillshade.tif in the directory qgis/Sleman/.

●

Check the box next to Load into canvas when finished.

●

You may leave all the other options unchanged.

●

Click OK to generate the hillshade.

●

When it tells you that processing is completed, click OK on the message to get rid of it.

●

Click Close on the main DEM (Terrain models) dialog.
You will now have a new layer called hillshade that looks like this:
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This looks more 3-Dimensional, but can we improve on this? On its own, the hillshade
looks like a plaster cast. It will look better if we can combine it with our more colorful
DEM. We can do this by making the hillshade layer an overlay.

3.2 Using a Hillshade as an Overlay
A hillshade can provide very useful information about the sunlight at a given time of day.
But it can also be used for aesthetic purposes, to make the map look better. The key to
this is setting the hillshade to being mostly transparent.
●

Change the symbology of the original DEM layer to use the Pseudocolor scheme.

●

Hide all the layers except the DEM and hillshade layers.

●

Click and drag the DEM to be beneath the hillshade layer in the Layers list.
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●

Control rendering order(beneath the list) should be checked as well.

●

Now we will make the hillshade layer somewhat transparent. Open its Layer Properties
and go to the Transparency tab.

●

Set the Global transparency to 50%:

●

Click OK on the Layer Properties dialog. You’ll get a result like this:
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●

Switch the hillshade layer off and back on in the Layers list to see the difference it makes.

Using a hillshade in this way, it’s possible to enhance the topography of the landscape. If
the effect doesn’t seem strong enough to you, you can change the transparency of the
hillshade layer; but of course, the brighter the hillshade becomes, the dimmer the colors
behind it will be. You will need to find a balance that works for you.
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Module 9
Create a New Vector Layer

Learning Objectives
●

Add a raster layer for digitizing

●

Create new vector features (polygons, lines and points)

●

Digitize a new vector layer by tracing the raster layer, considering topology

●

Georeference an image

Creating a map using data that already exists is only the beginning. We have already
learned how to edit and add features to OpenStreetMap using JOSM. In this chapter, we
will discuss how to edit existing vector layers in QGIS, and how to create an entirely new
dataset.
1. Adding raster layer
Before you can add new vector data, you need a vector dataset (a layer) to add it to. In
our case, we’ll begin by creating a new data layer, and then we’ll add features to it. First,
we must define our dataset.
●

Create a new project in QGIS, by clicking on the “New Project” icon.

●

Go to Layer ‣ New ‣ New Shapefile Layer. You’ll be presented with the following
dialog:
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At this point we must decide what kind of dataset we want to create. Remember that a
data layer can only contain features of points, lines, or polygons - never a mix. So we
must define here, when we create the layer, what type of data it will contain.
Since polygons are made up of points and lines, let’s jump into polygons. Once you’ve
mastered this, creating a point or a line layer should be easy!

●

Click on the Polygon radio button:

●

We’ll specify the Coordinate Reference System (CRS) in the next box. By default the
box will contain the CRS of the project, which for us will be WGS84. This is a widely
used and very useful CRS, so let’s stick with it!
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●

When we create our new layer, the attribute table will only have one column by default id. This attribute contains a unique id number for every feature. We can add additional
fields to the attribute table now, when we create the layer. Let’s add a name field.

●

Type “nama” into the box next to Name. The settings should match those shown here:

●

Click the Add to attributes list button.

●

Your attributes list should now look like this.

●

Click OK. A save dialog will appear.

●

Navigate to a directory of your choosing.

●

Save your new layer as gedung_kampus.shp.
The new layer should appear in your Layers list.

2. Creating new vector feature
When you create new data, it should obviously represent objects that really exist on the
ground. We have already learned of numerous ways to collect data using OpenStreetMap
tools. We learned about GPS to record locations, Walking Papers, and of course, aerial
imagery. These are all tools that we can use to identify real-life locations and record them
in a digital data layer.
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In QGIS, we can use the same types of sources to get information about the ground. In
this example, we will once again turn to aerial imagery, but instead of using Bing, we will
use a raster image provided in the tutorial directory.
●

Click on the Add Raster Layer button:

●

Navigate to qgis/Sleman/.

●

Select the file UGM.tif.

●

Click Open. An image will load into your map.

●

Find the new image in the Layers list.

●

Click and drag it to the bottom of the list so that it is below the vector layer you created in
the previous section.

●

Go to Project ‣ Project Properties... and enable “on the fly” transformation.

●

Make sure that “WGS 84” is selected as the CRS, and click OK.

●

Right click on the UGM layer, and click “Zoom to Layer Extent.”

●

Zoom in to the center of the raster image. We will be digitizing three areas:
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3. Digitizing
Digitizing, as you might have guessed, is the art (or science) of creating digital vector
data from another source, such as a raster image. In order to begin digitizing, we must
first enter Edit mode. GIS software commonly requires a separate mode for editing, to
prevent users from accidentally editing or deleting important data. Edit mode is switched
on or off individually for each layer.
Let’s enter edit mode for the gedung_campus layer:
●

Select gedung_campus in the Layer list.

●

Click on the Toggle Editing button:

●

If you can’t find this button, check that the Digitizing toolbar is enabled. There should be
a check mark next to the View ‣ Toolbars ‣ Digitizing menu entry.

●

Once you are in edit mode, the digitizing tools will become active:
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From left to right on the image above, they are:
●

Toggle Edit: activates / deactivates edit mode.

●

Save Edits: saves changes made to the layer.

●

Add Feature: start digitizing a new feature.

●

Move Feature(s): move an entire feature around.

●

Node Tool: move only one part of a feature.

●

Delete Selected: delete the selected feature (only active if a feature is selected).

●

Cut Features: cut the selected feature (only active if a feature is selected).

●

Copy Features: copy the selected feature (only active if a feature is selected).

●

Paste Features: paste a cut or copied feature back into the map (only active if a feature
has been cut or copied).

We want to add a new feature.
●

Click on the Add Feature button to start digitizing:

●

You’ll notice that your mouse cursor becomes a crosshair. This allows you to more
accurately place the points you’ll be digitizing. Remember that even as you’re using the
digitizing tool, you can zoom in and out on your map by rolling the mouse wheel, and
you can pan around by holding down the mouse wheel and dragging around in the map.

The first feature you’ll digitize is GSP field:
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●

Start by clicking on a point somewhere along the edge of the field.

●

Place more points by clicking further along the edge, until the shape you’re drawing
completely covers the field. This is very similar to drawing a polygon in JOSM.

●

To place your last point, right-click where you want it to be. This will finalize the feature
and show you the Attributes dialog.

●

Fill in the values as shown here:

●

Click OK. You’ve created a new feature!

Remember, if you’ve make a mistake while digitizing a feature, you can always edit it
later. Simply finish digitizing the feature and then follow these steps:
●

Select the feature with the Select Single Feature tool:
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Then use one of these tools to edit the feature:

●

the Move Feature(s) tool to move the entire feature,

●

the Node Tool to move only one point where you may have misclicked,

●

Delete Selected to get rid of the feature entirely so you can try again

●

the Edit ‣ Undo menu item or the ctrl + z keyboard shortcut to undo mistakes.

Now try it on your own:
●

Digitize the school itself and the upper field. Use this image to assist you:
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●

Remember that each new feature needs to have a unique id value!

When you are finished adding features to a layer, you must save the changes to that layer.
●

Click on the “Toggle Editing” button.

●

You will be asked to save your edits. Click “Save.”

Now you know how to create polygon features! Creating points and line layers is just as
easy - you simply need to define the type of layer when you create it, and of course you
can only create points in point layers and lines in line layers.
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4. Georeferencing
In the previous section we digitized a raster image, thus creating vector data. This is
essentially the same process as when we use Bing imagery in JOSM to add to
OpenStreetMap. And in both of these cases, the imagery that we use is already
georeferenced - that is, it is correctly placed in its proper location.
When an image is georeferenced, it is stretched in different ways so that each pixel in the
image corresponds as closely as possible to the area it represents on the spherical Earth.
Because it is difficult to perfectly align a flat image on a round object, there are often
small georeferencing errors, as we learned previously with imagery offset.
What if you have a map that is not georeferenced? What if you have a paper map given
to you by a government agency? How can you digitize it?
The first step is to turn your paper map into a digital image that you can manipulate with
your computer. You can do this with a scanner (or possibly a digital camera), although
doing so is beyond the scope of this chapter.

4.1 Georeference an Image
Now we will learn how to georeference an image in QGIS so that is correctly located on
Earth. We will be using a map provided in the tutorial files, which looks like this:
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●

Start a new QGIS project. Save your previous work if you like.

●

Go to Raster ‣ Georeferencer ‣ Georeferencer.

●

Click the “Open raster” button.

●

Find the file peta_krb_merapi_2002.jpg, which is located in the the folder
qgis/Sleman/Merapi. Click “Open.”

●

Select WGS 84 when prompted and click OK.

Unit 2: QGIS and InaSAFE Beginner Level | 115

In order to georeference this image, we need to associate points on the image to known
points on the Earth. Such points are called ground control points (GCPs). Luckily, this
map image has latitude and longitude coordinates written on it at every corner. So, to
georeference this image, we will create four GCPs, one at each corner of the map, and we
will turn our jpeg file into a geotiff, a georeferenced image.

●

Zoom in to the upper-left corner of the map by using the zoom button.

●

Click the “Add point” button.

●

Click on the very top left point of the map, right where the top border of the map meets
the left border.

●

A box will pop up requesting the x and y coordinates of the point you just clicked.
Luckily, the coordinates are written in blue on the map. The longitude (x coordinate) is
110° 15’ 00” E and the latitude (y coordinate) is 7° 29’ 47” S. We can enter the
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coordinates in the box as follows. Remember that south and west coordinates will be
negative numbers.

●

Click OK.

●

You will see a red point appear showing the location of your control point, and an entry in
the table at the bottom.

●

Repeat this process, creating ground control points at each of the four corners of the map.
Remember to enter the longitude and latitude that is written at each corner. When you are
finished, you should have four GCPs and your table will look like this:

●

Lastly we will adjust the settings and then create our output file.

●

Click on the “Transformation settings” button.

●

Next to “Transformation type” select “Linear.”

●

Provide a filename for the output raster. The file type will be .tif

●

Check the box next to “Load in QGIS when done.” It should look like this:
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●

Click OK.

●

Then look at the table

●

Make sure the residual value is near zero to improve accuracy.

●

Now we are ready to produce the georeferenced image file. Click on the “Start
georeferencing” button.

●

If you are asked to select the layer’s coordinate system, choose WGS 84.
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●

Go to Settings ‣ Project Properties and make sure that on the fly transformation is
enabled.

●

The output .tif file will be created and automatically added to your project. If you hover
over the image, you should see coordinates at the bottom of QGIS which are close the the
coordinates you entered when placing the GCPs.

●

Another way to see that the image is correctly placed is by adding a layer with the
OpenLayers plugin. Here we have added Bing satellite imagery, and made our new
geotiff transparent to see Merapi in the background.

Knowing how to georeference is important when you want to digitize from a paper map
or an image that is not already georeferenced. Once you have georeferenced an image
like this, you can apply the same digitization techniques that we learned previously in this
chapter to create vector shapefiles that can be used in QGIS and InaSAFE.
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Module 10
Vector Analysis for Problem Solving

Learning Objectives
●

Explaining GIS processes

●

Identifying problems

●

Explaining data needed

●

Starting a project

●

Analyzing problems

●

Identifying hazard zone

●

Looking for Important Roads

●

Looking for Medical Facilities

●

Buffering Roads

●

Buffering Medical Facilities

●

Analyzing Overlapped Areas

●

Choosing Farms and Moors

The power of GIS is its ability to help us analyze data. Vector data can be analyzed to
reveal how different features interact with each other. In this chapter, we’ll work through
the GIS process, attempting to solve a problem, and as we proceed, we will learn about
various analysis tools that QGIS provides.
1. The GIS Process
Before we start, it would be useful to give a brief overview of a process that can be used
to solve any GIS problem. The steps are simple:
1.

State the Problem
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2.

Get the Data

3.

Analyze the Problem

4.

Present the Results

2. The Problem
Let’s start off the process by deciding on a problem to solve. Let’s say you’re a disaster
manager, and you need to provide the best locations to place refugees (IDPs) in villages
surrounding Mount Merapi when it erupts. You’ve come up with the following criteria for
these locations:
1. The area should be a dry field or farm in the districts Ngemplak, Turi or Pakem.
2. The area must be outside of Merapi Eruption Disaster Prone Region III.
3. Access to the site should be easy, so it will not be more than 300 meters from a main
roads.
4. The site should be close to health facilities.
5. The land area should be between 50000-150000 m².

3. The Data
To answer these questions, we’re going to need the following data:
1. Landuse in Sleman regency
2. Streets in Sleman
3. Location of health facilities
4. KRB Merapi (Merapi Eruption Disaster Prone Region - this is the same data that we
learned how to georeference in the previous chapter)
For this exercise the data has been provided already, but in a real scenario you may need
to find providers for the datasets in question. In Indonesia, the National Land Agency
and BNPB Bappeda are good sources for the types of data you will need, and
OpenStreetMap can be used as a source for roads and infrastructure.

4. Start a Project
So now that we know what we want to do, let’s start doing it!
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●

Start a new QGIS project.

●

Start adding the layers we will use. In the Sleman/Merapi folder, add the layers
jalan_sleman_49S, tempat_penting_Sleman_49S, KRB3_49S and vegetasi_49S. Your
Layers list should look like this:

NOTE: Most of the layers are pretty self-explanatory, but
what are KRB3, KRB2, and KRB1? These layers show areas of
impact when Merapi erupts. KRB3 is the area of worst
impact, KRB2 is medium, and KRB1 has little impact. In
this scenario we want to find locations that are not within
KRB3.

The data we are working with now is similar to that from previous chapters, but now it is
in a Projected Coordinate System. The previous data was saved in WGS84 - this meant
that the coordinates of our features were stored in degrees, which aren’t very good for
measuring size or distance. By using a projected system our coordinates are in meters,
which is important for analysis, because we can easily measure distances between and
around features.

●

Rename the layers by right-clicking on them and selecting the Rename option.

●

Give them the new, simpler names jalan, lokasi_penting, KRB III and vegetasi.

●

Save your map as merapi_analisis.qgs.

●

In your operating system’s file manager, create a new folder under qgis/Sleman/Merapi
and call it evakuasi_bencana. This is where you’ll save the datasets that we will create
during our anaysis.
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Now that we’ve got the data, let’s analyze the problem!

5. Analyzing the Problem: Farms and Dry Fields
The first criterion we’re facing is that the land must be a farm or dry field, and it must be
in one of three areas. So let’s tell QGIS to only show us the farms and dry fields that are,
in fact, in these sub-districts!
●

Right-click on the vegetasi layer in the Layers list.

●

Select the option Filter This opens the Query Builder dialog.

●

Scroll down in the Fields list on the left of this dialog until you see the field kec.

●

Click on it once.

●

Click the All button underneath the Values list:
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We are going to build a query. A query is a statement that allows us to show only the data
that we want from a layer. In this case, we want to instruct QGIS to only show us farms
and dry fields which have a sub-district value equal to Ngemplak, Turi, or Pakem.
●

Double-click the word kec in the Fields list.

●

Click the = button (under Operators).

●

Double-click the value Ngemplak in the Values list.

●

Click “OR”.

●

Repeat these steps twice more, using the values Turi and Pakem instead of Ngemplak.
The query should look like this:
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●

Click “AND”.

●

Now highlight guna_lahan in the Fields list, and click the “All” button to load the
values.

●

Double-click guna_lahan. Then click the = button. Then double-click the value
KEBUN.

●

Click “OR”.

●

Repeat the previous step but instead of KEBUN use TEGALAN. Your query should look
like this:

●

The idea is that query will filter the data layer so that it will only show us features that we
want - that is, farms and dry fields in Pakem, Turi, and Ngemplak. But we need to add
one thing to our query: parentheses. Without these, our query won’t work quite right. We
need to add two pair of parentheses on each side of the word AND, like so:

●

Click OK. Our vegetasi layer has far fewer features now.
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Well done! We’ve applied our first criteria to begin solving the problem!

6. The Danger Zone
Our next criteria is that our chosen location should be outside of the danger zone, which
is defined by the layer KRB III. For this we can use the Spatial Query tool.
●

Go to Vector ‣ Spatial Query ‣ Spatial Query.

●

Under “Select source features from” choose “vegetasi”. In the next box choose “Is
disjoint.” The third box should be set to “KRB III”. The Spatial Query window should
look like this:
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●

Click “Apply.” Then click “Close” once the selection has been applied.
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Now the vegetasi layer looks like the image below. Notice that all the features have been
selected that fall outside the KRB III area.

The next steps of our analysis will be easier if we save this selection as a separate layer.
●

Right-click on the vegetasi layer and click Save Selection As....
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●

Next to the Save as field in the dialog that appears, click the Browse button.

●

Save the layer under evakuasi_bencana/, as kebun_tegalan.shp

●

Check the Add saved file to map box in the Save vector layer as... dialog.
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●

Click OK. It will tell you that Export to vector file has been completed.

●

Click OK.

●

Right-click on the old vegetation layer and remove it. You should have these layers
remaining:
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7. Finding Important Roads
We have a problem with our roads layer, similar to that of our vegetation layer. Our roads
layer has too many roads! We only want to use main roads for our analysis, so that we
can meet the criteria that our location is within 300 meters of a major road. Once again,
we will use the Query Builder.
●

Right-clck on the jalan layer and click Filter

●

Build a query for the roads layer, like you did above for the vegetation layer. You want
only the types primary and secondary, so you need to build this query:
"TYPE" = 'primary' OR "TYPE" = 'secondary'

●

You can use the approach that we learned above, or you can simply type this command
into the query box. But be careful that you type it correctly!

8. Looking for Health Facilities
●

Using the same approach, build a query for the lokasi_penting layer as shown:
"Fungsi" = 'Kesehatan'

9. Buffering Roads
Okay, we’ve refined our data a bit so that it shows us the features we are interested in
analyzing. Remember that according to our criteria our land area should be within 300
meters of a main road and close to a health facility. QGIS allows us to calculate distances
from any vector object, and we will use this functionality to help us reach a solution.
●

Make sure that only the jalan and kebun_tegalan layers are visible, to simplify the map
while you’re working.
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●

Go to Vector ‣ Geoprocessing Tools ‣ Buffer(s).

●

In the first dropdown box choose “jalan”
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●

Enter “300” next to Buffer distance.

●

Check the box next to “Dissolve buffer results.”

●

Click Browse and type buffer_jalan_300m.shp for the filename.

Note that we input the buffer distance in meters. Good thing we used projected data!
●

Click OK. QGIS will create a buffer around the streets that extends 300 meters.

●

When you are asked to add the new layer to the TOC, click “Yes.” (“TOC” stands for
“Table of Contents”, by which it means the Layers list)

●

Close the Buffer dialog and witness your new layer:
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Interesting! Those big fat lines are actually areas that are within 300 meters of primary
and secondary roads.

10. Buffering Health Facilities
●

Now try it yourself! Using the same approach, create a new buffer layer around your
health facilities. The buffer should be 2.5 km in radius,

●

Don’t forget to check the box “Dissolve buffer results” so every overlapping buffer will
become 1 feature. Then save the new layer in the same directory as
buffer_fas_kesehatan_2.5km.shp. Your resulting map will look something like this:
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HINT: Remember that the buffer distance is in meters. Keep this in mind when you
want to create a 2,5 km buffer!

11. Overlapping Areas
Now we can see areas where a main road is 300 meters away and where there is a health
facility within 2.5 km. But we only want the areas where both of these criteria are
satisfied at once! To do that we will use the Intersect tool.
●

Go to Vector ‣ Geoprocessing Tools ‣ Intersect.
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●

Enter buffer_fas_kesehatan_2.5km and buffer_jalan_300m as the two input layers.
Name the output shapefile intersect_buffer_jalan_kesehatan.shp.

●

Click OK and add the layer to the Layers list when prompted.
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●

If we hide the original layers, we can see that our new layers shows us the areas where
they intersect. These are the areas where both of these criteria are satisfied.

12. Select Farms and Dry Fields
Now we have the layer kebun_tegalan, which satisfies two of our criteria, and the layer
intersect_buffer_jalan_kesehatan.shp which satisfied two other criteria. We need to
know where they overlap!
●

Go to Vector ‣ Research Tools ‣ Select by location. A dialog will appear.
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●

Set it up like this:

●

Click OK and you’ll see the results are slected (they are yellow)
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Let’s save this selection as a new layer.
●

Right-click on the kebun_tegalan layer in the Layers list.

●

Select Save Selection As....

●

Name the new file kebun_tegalan_lokasi_terpilih.shp and check the box next to “Add
saved file to map.”
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●

If we hide all the other layers, we can see the resulting layer:
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13. Select Land Areas of the Appropriate Size
Hooray! We have now found land areas that meet four of our five criteria. The only
remaining criteria is the size of the land. We need to make sure that our possible
locations are between 50000-150000 m².
●

Open the attribute table for the kebun_tegalan_lokasi_terpilih layer. You’ll notice that
there is a column named luas_ha. This is the size of the area in hectares. We could use
this field to answer our question, but let’s add another column that contains the size of the
area in square meters.

●

Select the kebun_tegalan_lokasi_terpilih layer and Open Attribute Table

●

Enter editing mode by clicking this button:

●

Start the field calculator (located in the Attribute Table window)
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●

Check the box next to “Create a new field”. In the box type “luas_m2.”

●

Change Output field type as Decimal number (real), then click on “Geometry,” and then
double-click “$area.”

●

Click OK.

●

You should now see a new column on your attribute table, named luas_m2. And QGIS
has filled it in for us with square meters!
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●

Click the edit mode button again, and save your edits.

●

Close the attribute table. Now we can just do a simple query.

●

Right-click on the kebun_tegalan_lokasi_terpilih layer and click Filter

●

Enter the following:
"luas_m2" >= 50000 AND "luas_m2" <= 150000

●

Click OK.
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That’s it! We have eight pieces of land that meet ALL of our criteria. Any of these pieces
of land might be suitable for a location to place refugees. Then you can right-click
kebun_tegalan_terpilih layer and Save As a new layer. Give the file name
refugees_location.shp
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Module 11
Using Map Composer

Learning Objectives
●

Arrange map layout

●

Adding new map

●

Add title to a map

●

Add graphic and numeric scales

●

Add grid to a map

●

Adding inset

●

Customize the content of the legend

●

Export a map to different formats (pdf, jpeg, svg)

Your map is a means to communicate information (as well as new ideas and you) to the
map reader. You use symbology to convey the contents of your data so it can be easily
understood. When you create a map layout, you go one step further - you present your
map so that it becomes a means of information.
No matter what media you plan to distribute your map by (whether it’s printed or sent
over the internet), you must pay attention to how you compose your map elements in the
layout. In this chapter we will discuss the presentation of printed maps, and create our
very own.

1. The Map Composer
The QGIS Map Composer allows you layout your map and prepare it for printing. Apart
from your map, you are able to add additional information such as images, labels,
legends, and scalebars.
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●

Let’s start with some data in the Sleman regency that has already been symbolized. Open
the project named print_2_11.qgs in the qgis/ directory.

●

This map shows some familiar layers from the previous chapter. We have the roads and
vegetation of Sleman, along with the three impact zones from a Merapi eruption model.

●

Let’s see how we can use Map Composer to adjust the layout and prepare this map for
printing.

●

Go to Project ‣ New Print Composer. Then, give an unique title name for your layout, for
example: My Layout 1. Click OK, then a new window will load that looks like this:

This is the window where you can compose the layout of a map that you want to print.
The blank white area is your “canvas,” or in other words, a model of the paper you are
going to print out. You can put various elements onto this canvas, such as your map
(obviously), a title, scalebar, legend, and so on. These are elements commonly used on
printed maps.
Take a look at the right panel. In Composition tab, you change paper size, number of
pages, and quality of output.
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Take a look at the icons across the top of the window. We will use some of these as we
lay our map out, so here’s an overview of what they do:

Add New Map will add a map element. This is what we will use to add the map
from our project into our print layout. It should be noted, however, that if we change the
map in our QGIS project, it will not update the same map that we have added to our print
composer, as we shall see later.
Add Image allows us to add a picture. You can add a company or organizational
logo, or simply display images from a particular location. You can also add an image of a
compass (to point North).
Add New Label is used for adding text to the layout, such as titles or other
information.

Add New Legend is for adding a legend, which will conform to the active layer
in the QGIS window.

Add New Scalebar is used to add a scale to the layout.
Add Ellipse/Triangle/Rectangle is used to add one of these geometric shapes.
For example, this might be used to indicate special areas or highlight things on the map.
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Add Arrow is used to draw an arrow on the map layout.

Select / Move Item allows us to move choose and move the elements that you
add to the map layout. With this tool selected, you can right-click on an element to lock
its position.

2. Add New Map
●

In the Print Composer window, click on the “Add new map” icon.

●

Next, click and drag your mouse across the canvas, creating a box. Your map layout
should look similar to this when you are done:

●

If you are not happy with the placement of your map, you can drag the corners to change
the size, or drag the entire element around the canvas.

●

Once you are happy set the scale of your map by going to the “Item Properties” tab on the
right panel.

Unit 2: QGIS and InaSAFE Beginner Level | 148

●

Edit the Scale and press Enter. You’ll see that the scale (zoom level) of the map element
changes. A scale of about 200000 should be good for this project.

●

You also can add frame by clicking box next to “Frame”. And you can configure the
frame color and border thickness.

●

Note that when you change the scale some parts of your map may become invisible.
Click on the “Move item content” button and drag the map so that it is all visible.

3. Add a Title
●

Now we’ve got the most important thing added to our map layout - the map! But let’s
add some additional elements to make it more informative.
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●

Let’s add a title to our map. Click on the “Add new label” button.

●

Adjust the size of the element. We will edit the text and the text properties in the panel
on the right.

●

Click the “Font” button and change the text size to 18 and make it bold. Change the
aligment to center. Lastly, add the following text, or create your own:

●

Your map layout should now look similar to this:
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4. Add a Scale Bar
●

Let’s add a scale bar, so that anyone who looks at our map will have an idea what size
area this map shows. Click on the “Add scale bar” button.

●

Draw the new scalebar element on your map. A good location for it is in the lower left
corner of your map layout.

●

Next we need adjust the scalebar options. Since our project is in a PCS (Projected
Coordinate System), our measurements are in meters. Enter the following values in the
scalebar options:
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●

This should result in a scalebar that looks like this:

5. Create a Grid
●

Now let’s create a grid for our map.

●

Choose the “Select” tool and click on the map.

●

In the panel on the right you should see the word “Grid.” Click on it.

●

Check the box next to “Show grid” and enter the following values:
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●

Check the box next to “Draw Coordinates” and enter the following values:
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●

Your map should now have a grid appear over it, which will look something like this:

Tips:
1.
Play around a little bit with coordinate format.
You can change the coordinate format either with Decimal like we set on the
example, or you can change it into Degree Minute format (DD MM) or Degree
Minute Second (DD MM SS).
2.
Also you can play with coordinate placement.
You can place inside frame or outside frame. And the orientation either vertical or
horizontal.
3.
You also can change the font type and font size
by clicking Font on the panel
6. Overview Inset
●

Next, let’s add an inset that gives views of our map a little more information about what
they are looking at. Minimize the Print Composer and go back into QGIS.

●

Add the layer Indonesia.shp, which is located in qgis/peta_dunia. Cllick “Zoom Full.”

●

You will see the new layer load.
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●

Return to the Map Composer and create a new map with the “Add new map” button.

●

Draw a small box on the right side of your map layout.

●

The current view of your QGIS project will appear in the new map element (but notice
that the old map element doesn’t change!). Add a frame for the inset, so it will look like
this:

7. Add a Legend
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Now let’s add a legend so that viewers of our map will know what our symbology
represents.
●

Click on the “Add legend” button.

●

Draw a box in the remaining empty space on our map layout. You will see a legend with
all of our symbologies shown in a list.

●

In the panel on the right, click on “Legend items.” Use the edit button to change the
names on the legend. Use the + an - buttons to add or remove items from the legend.
You may choose which elements are important to include.

Our legend has been made to look like this:
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When you are finished, your map layout should look similiar to this:
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8. Printing the Map
●

Lastly, you can print your map. This part is easy, you can simply click the “Print” button
and follow the dialog.

●

You also can save the map as PNG image.

●

Additionally you can save the map as a PDF, which you can easily send over email or
print later when you have a chance.
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Module 12
Understanding InaSAFE

Learning Objectives


Explaining the concept of Hazard, Exposure, and Impact data



Explaining how to get Impact



Explaining InaSAFE’s interface



Adding hazard data



Adding unprocessed exposure data (vector and raster)



Using keywords editor



Analysing Impact



Improving InaSAFE Output Map



Saving and Printing scenario result

1. Hazards, Exposures and Impact
Let’s being by reviewing the inputs and outputs of InaSAFE - hazard, exposure, and
impact. These terms are important for you to remember because the analysis process
will always depend on these three things.
Hazards (also called disasters) are what we call the data layers (layers) that describe the
extent and magnitude of natural events (such as earthquakes, tsunamis, volcanic
eruptions) that could potentially cause an event or series of events that threaten and
disrupt the lives and livelihoods of people.

Generally, hazards that we model:
●

are at a particular location

●

have a measured intensity

●

have a measured duration
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●

have a certain time frame
In this chapter we will use a dataset modelled from an earthquake in Lembang.

Exposure data represents things that are at risk when faced with a potential hazard. This
can be man-made features such as public buildings, houses, roads, and bridges, or it can
be so-called natural features, such as population, rice paddies, and lakes. These exposed
elements can be divided into various categories, including physical elements (houses,
power lines), economic elements (agricultural land, access to employment), social
elements (vulnerable groups, population density), and environmental elements (air, water,
plants and animals).

Previously we ran InaSAFE with exposure data consisting of population data from
AsiaPop, and building data from OpenStreetMap. In this chapter’s analysis we will once
again use OSM data.

Impact is the result we get after InaSAFE processes the effect of the hazard data upon the
exposure data. For example, if there is an earthquake model in Lembang, and we process
it against building data in Bandung, our impact layer may show those houses that would
be severely damaged, those somewhat damaged, and those mildly damaged. In other
words, what goes in to InaSAFE are hazards and exposure. What comes out is impact.
2. The InaSAFE Interface
Before we run any scenarios, let’s take a closer look at the InaSAFE interface. Make sure
you’ve installed InaSAFE plugins (see Module 4 for reference if you forgot how to do it)
Open a new project in QGIS.
If the InaSAFE toolbar is not visible, right-click on the toolbars and make sure that
“Plugins” is checked. The toolbar looks like this:

Toggle InaSAFE Dock

This button enables and hides the InaSAFE dock. After enabling the dock you are able to
move it around your screen. Dock and undock it wherever you want to have it and keep it
even as a separated window.
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InaSAFE Keyword Editor

The Keyword Editor button opens the Keyword editor which basically enables you to
easily edit the Keywords needed for InaSAFE to create useful output.
InaSAFE Options

This button opens the Options window.
InaSAFE Impact Functions Browser

This button opens the Impact Function Browser.
It basically enables you to filter and browse impact functions that are available in
InaSAFE.
InaSAFE Minimum Needs Tool

This tool will calculated minimum needs for evacuated people.
InaSAFE Converter

This tool will convert an earthquake ‘shakemap’ that is in grid xml format to a GeoTIFF
file.
InaSAFE Batch Runner

The Batch Runner lets you load saved scenarios (Save Scenario) and batch run them in
one go.
Save current scenario

This is the tool you need to prepare/save scenarios for the InaSAFE Batch Runner Tool. It
lets you save the current visible scenario in QGIS to a .txt file. This file you can open as a
scenario again in Batch runner and recalculate it.
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InaSAFE OpenStreetMap Downloader

This tool will fetch building (‘structure’) and roads (‘highway’) data from the
OpenStreetMap project for you.

●

To start using InaSAFE, activate the InaSAFE panel by clicking on the button named
“Toggle InaSAFE dock.”

●

Note that just like QGIS toolbars, you can drag and drop the InaSAFE dock panel to
change its position on the QGIS interface. You can pull it away as a separate window, or
place it below the Layers list. It’s quite convenient in its location on the right side of
QGIS, so we will leave it there.

Unit 2: QGIS and InaSAFE Beginner Level | 162

The InaSAFE panel consists of three parts: Questions, Results and Buttons. The
questions are mixed in with dropdown boxes - this is where we establish our input data
and define the scenario that we want InaSAFE to process. The purpose of InaSAFE is to
make your impact analysis very simple and easy to do. The Questions section provides a
simple way for you to formulate what you want to know. All questions are created in the
following format:

In the event of [hazard] how many [exposure] might [impact]?
For example: "In the event of an earthquake how many buildings
might be closed?"

The other parts of the InaSAFE we have seen in action. The Results section is filled in
with information once InaSAFE is run, and the Buttons allow us to run a scenario, print,
and access help.

3. Adding Hazard Data
Hazards can be represented by vector layers or by raster layers. Remember that raster
layers are like images with many pixels, and each pixel represents some data about an
area on the ground. A raster that shows elevation, for example, will contain pixels with
different values based on the altitude of the location. Similarly, a raster that represents an
earthquake will contain the magnitude of the earthquake at the time of the event in every
pixel in the raster.

An earthquake can also be modelled with vector data, although the detail of the data will
most likely be lower. In this case vector polygons will represent the area where the
earthquake occurred, and possibly various polygons will show areas of differing
magnitudes.

Let’s begin by adding our hazard layer to QGIS. It’s a raster model of an earthquake in
Lembang.
●

Click the “Add Raster Layer” button.
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●

Navigate to the qgis/Bandung folder and add Lembang_Earthquake_Scenario.asc. This
data is raster data (in ASCII format) which represents the magnitude of the earthquake.
The layer will look like this:

Try to change the layer band into Singleband Pseudocolor until the layer look like this
image below (refer to Modul 8, if you forgot how to do it!):
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You will notice that the hazard dropdown box has been automatically filled in the
InaSAFE panel. This is because the data file has already been prepared for us with
keyword metadata (fancy words for settings) that tells InaSAFE whether it’s a hazard or
exposure layer. When we add the exposure data, we will learn how to do inform
InaSAFE ourselves.

4. Exposure
Exposure can also be represented by vectors or rasters. In fact we’ve already seen this in
the Jakarta flood scenario. When we ran that analysis our population layer was a raster,
with each pixel representing the population of a given area on the Earth. Our buildings
on the other hand, were vectors.

Let’s add our exposure data to QGIS - once again we will be using buildings obtained
from OpenStreetMap.
●

Click on the “Add Vector Layer” button.

●

Add the file Bangunan_Bandung.shp, which is located in the qgis/Bandung folder.
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●

Notice that unlike the hazard layer, it does not appear automatically in InaSAFE!

5. Adding Keyword Metadata
In order for InaSAFE to know that our layers are hazard or exposure datasets, we need to
assign keywords to the layers using the InaSAFE keyword tool. Let’s take a look at the
keywords that have already been created on the hazard layer.
●

Select the earthquake layer in the Layers list, and click on the “InaSAFE Keyword
Editor” button.

●

You can see that this layer has already been assigned some keyword information for
InaSAFE, including its title, a category, and a subcategory.
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●

Click OK, and now select the Bangunan_Bandung layer and open the keyword editor.

●

You’ll notice that title and category are set, but not the subcategory!

●

Change this to “structure,” and then click OK.

●

Notice that the layer now appears in the InaSAFE dock panel.



Now click, Run to calculate impact analysis and wait for a moment.

6. Impact Analysis
Now our hazard and exposure data are set in the InaSAFE panel, because the appropriate
keywords have been added to our layers. Note that if we were to add a second exposure
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layer to our project, we would be able to choose which exposure layer we wanted from
the InaSAFE dropdown menu. The same applies to hazard layers.

The third dropdown box is the impact function (“Might”). This concludes our question,
and defines the function that InaSAFE will run behind the scenes. InaSAFE developers
have written many of these functions to analyze all sorts of hazard and exposure layers.
The function that is selected for us here will process the hazard and exposure layers
spatially to determine how the exposure layer will “be affected.”

●

Click the “Run” button at the bottom to start the impact analysis. In the end of the
process, statistic will be shown on the result panel and new layer will be added into layer
list to explain the result of analysis.

7. Improve the InaSAFE Output Map
We can improve our impact map by editing the symbology in QGIS. Styles can be
changed, other relevant layers can be added, and the layout can be changed using the
Print Composer.
Let’s add Bing aerial imagery as a background for our map.
●

Go to Plugins ‣ OpenLayers plugin ‣ Add Bing Aerial layer.
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●

Drag the layer below your new impact layer.

8. Using the Print Button
The data displayed on the screen can be saved to a PDF file by clicking Print at the
bottom of the InaSAFE panel.





Klik on InaSAFE result layer, then click “Print”
A window will show up, you can choose the extent that you want to be
printed.
- Analysis extent if you want to print all the analysis result
- Current extent if you want to print analysis result based on QGIS map
canvas
You also can pick the template (basic or InaSAFE). If you have QGIS
composer template file (.qpt format), you also can use it. For now, let’s
choose Basic.
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If you want to add additional information on your layout before it will be
printed, you can click “Open Composer”. If you want to save it in PDF
format to print it, click “Open PDF”
Choose your save location and click “Save”.
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9. Save Your Results
You can save the impact layer that InaSAFE created, and you can save the QGIS project
to come back to it later, but note that the InaSAFE statistics cannot be saved (except when
you save them in a PDF). To get the statistics again in QGIS, you will need to run the
analysis again.
●

To save the newly generated layer, right-click on it in the Layers list.

●

Click Save As...

●

Select a name and location for the file. Click OK.

To save the project:
●

Click on the “Save Project” button at the top of QGIS.

●

Give a name to the project and put it in the directory you want to save your work. Then
click Save.

Saving your scenario
You also can save your scenario using. The Save current scenario tool lets you save
scenarios and batch run them again in the batch runner tool in one go.
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InaSAFE Save current scenario tool
This is the tool you need to prepare/save scenarios for the InaSAFE Batch Runner Tool. It
lets you save the current visible scenario in QGIS to a .txt file. Once saved you can
reopen this file as a scenario again in Batch runner and recalculate it.
Please note that this tool currently does not store the impact function parameters you may
have set. Consequently all impact functions will run using their default options.

Running scenario using Batch Tools

InaSAFE Batch Runner tool
With Batch Runner tool you can setup numerous scenarios and run them all in one go. A
typical use case may be where you define a number of e.g. flood impact scenarios all
using a standard dataset e.g. flood.shp. As new flood data becomes available you replace
flood.shp and rerun the scenarios using the batch runner. Using this approach you can
quickly produce regional contingency plans as your understanding of hazards changes.
When you run the batch of scenarios, pdf reports are generated automatically and all
placed in a single common directory making it easy for you to browse and disseminate
the reports produced.

Module 13
Getting Support
Learning Objectives
● Using social media to keep the interaction alive
● Accessing QGIS tutorial website
1. Facebook
With the development of social media today, it is great that QGIS and InaSAFE users can
exchange ideas online. One common platform that can be used is Facebook. You can
join the Facebook group Forum Pengguna QGIS dan InaSAFE Indonesia to discuss
the experiences or difficulties you have using QGIS and InaSAFE.
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2. QGIS Tutorials
You can also obtain a variety of tutorials and the latest information about QGIS at
http://osgeo.ft.ugm.ac.id/ address. You can download more training materials here.
On this page you will also find contact information for the QGIS Indonesia forum, if you
need assistance at any time regarding the use of QGIS or InaSAFE. Please stop by
whenever you want!
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